[lxc-users] macvlan networking

Fajar A. Nugraha list at fajar.net
Mon Sep 15 09:25:03 UTC 2014

On Mon, Sep 15, 2014 at 4:19 PM, Adam Gold <awg1 at gmx.com> wrote:
>> The "official" networking guide for lxc on Ubuntu :
>> https://help.ubuntu.com/14.04/serverguide/lxc.html#lxc-network
>> At first glance your config looks correct, but the most obvious
>> possible source of problem would be "-i eth0". You said that your
>> public IP is now on br0. I'd try to remove the "-i" part altogether,
>> to see if it is indeed the source of problem.
> eth0 and br0 are the same interface, it's just the name on the inside vs
> the outside of the container.

No, it shouldn't be the same.

br0 -> bridge (on host)
bond0 -> bond interface, which has eth0 as slave (on host)
vethXXX -> veth interface for the container (on host)
eth0 (on container) -> the pair of vethXXX on host

Unless I misunderstood something?

>  I tried removing all of the -i sections
> but still no luck :(
> Here's the strange thing: if I set up the host to forward to a container
> on the lxcbr0 interface / internal network it works fine.  However

... because the container uses the host as its gateway

> forwarding from a dual public/private interfaced container to a private
> container doesn't work.

Does the private container use the private interface of the
dual-interface container as gateway?

If not, then it wont work.


More information about the lxc-users mailing list