[lxc-users] Macvlan setup issues

Mark Haney mark.haney at vifprogram.com
Fri Apr 29 12:39:58 UTC 2016

Well, as this is a VM running on an ESXi 6 cluster, I'm having a hard time
believing that would be the case.  However, just to make certain, I've
created the bridge manually and still have the same problem.  If our
switches (Cisco 3750s) had issues with running multiple MACs on the IBM
Blade Server NICs, I'm pretty sure we'd have seen that long ago.

Any other ideas?  Or should I just scrap this entire setup since it appears
that only LXD experts can manage to get this particular setup working

On Fri, Apr 29, 2016 at 2:22 AM, Fajar A. Nugraha <list at fajar.net> wrote:

> On Fri, Apr 29, 2016 at 12:02 AM, Mark Haney <mark.haney at vifprogram.com>
> wrote:
> > Hi all.  I'm really new to LXC/LXD as well as with macvlan setup, so bear
> > with me.  I'm having all kinds of trouble getting the macvlan setup to
> work
> > on my Ubuntu 16.04 VM.  The documentation isn't terribly clear, or at
> least
> > it seems to be missing something that is keeping my containers from being
> > accessible inside my office network directly.  I'm hoping it's something
> > simple, but as I've run out of good Google searches, I'm not sure what
> else
> > to try.  Here's my problem (and setup):
> >
> > I've been able to get containers of various distros running file with
> > bridging, but I'd like to be able to access them as part of my LAN
> directly.
> >
> >
> > The IP of the 16.04 host: (gw
> >
> > Now, I went through the docs to setup macvlans as this appeared to be the
> > simplest (best?) method of setting up the containers to access my LAN.
> So,
> > I ran dpkg-reconfigure lxd and removed the bridging.  Then set the
> macvlan
> > according to the docs:
> >
> > lxc profile device set default eth0 nictype macvlan
> > lxc profile device set default eth0 parent ens160
> >
> > The second command might not be correct, as the documentation doesn't
> > specify precisely what the 'parent' is, though I believe it's the host
> > interface name (in my case ens160).  Regardless, this seems to have
> worked,
> > at least partly because, when I launched an image of Ubuntu 15.10, the
> eth0
> > interface was correctly given a DHCP address from my LAN (
> and
> > a default gateway (
> >
> > However, I cannot ping anything on my network from the container with a
> > 'Destination Host Unreachable' message.  IP forwarding is enabled, but I
> > don't think I need that for this setup.  The problem is, none of the docs
> > say I need to do anything else to get macvlans working, which is why
> this is
> > so frustrating.  Is this just a case of I'm missing something the docs
> > assume I have knowledge of?  Or an actual problem.
> >
> > I'm no Linux slouch, I've been using them since the RH3 days, but
> macvlans
> > are new to me, so is LXD.
> The usual questions:
> - do you get the SAME result when you use a MANUALLY created bridge
> with eth0 as one of the slaves?
> - does your network (e.g. switch) allows multiple macs on a single port?
> The usual culprit (e.g. with EC2) is that the network only allows one mac.
> --
> Fajar
> _______________________________________________
> lxc-users mailing list
> lxc-users at lists.linuxcontainers.org
> http://lists.linuxcontainers.org/listinfo/lxc-users


Mark Haney ::: Senior Systems Engineer
*VIF* *International Education*
P.O. Box 3566 ::: Chapel Hill, N.C. 27515 ::: USA
919-265-5006 office

Global learning for all.
Find VIF on Facebook <http://facebook.com/VIFInternationalEducation> |
Twitter <https://twitter.com/vifglobaled> | LinkedIn

Recognized as a ‘Best for the World’
<http://bestfortheworld.bcorporation.net/> B Corp!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxcontainers.org/pipermail/lxc-users/attachments/20160429/84a8991c/attachment.html>

More information about the lxc-users mailing list