[lxc-users] Error on nested LXC-ibvirt container

Serge Hallyn serge.hallyn at ubuntu.com
Wed Apr 30 13:36:40 UTC 2014

Quoting CDR (venefax at gmail.com):
> Dear Friends
> I defined a new network for libvirtd, after the default network gave
> me the same error:
> virsh net-start nat
> error: Failed to start network nat
> error: Unable to set bridge nat0 forward_delay: Read-only file system

Do you have apparmor enabled?  We recently updated the apparmor profile
such that it should allow writing to the bridge's forward_delay file.
I've definately installed libvirt inside containers before (not with the
most recent apparmor profile), and apart from enabling that in apparmor
and manually creating /dev/net/tun and /dev/kvm, it worked fien.

> Is there any work around? I need to have two levels of nested containers.
> Rest assured that the file system is not read-only.
> Federico
> _______________________________________________
> lxc-users mailing list
> lxc-users at lists.linuxcontainers.org
> http://lists.linuxcontainers.org/listinfo/lxc-users

More information about the lxc-users mailing list