[Lxc-users] Alternative to Debian Testing? No Prompt upon lxc-console execution

Terry--gmail terry.kemmerer at gmail.com
Wed Feb 22 15:38:33 UTC 2012

For the record, I'm not married to using Testing repositories. I just 
need a way to
get working squeeze containers....that at my dummy level I can create 
and work with. :)

I wasn't using wheezy, I was using debian squeeze on my host node and added
the associated Testing Repositories to my /etc/apt/sources.list:
deb ftp://ftp.lt.debian.org/debian/ testing main non-free contrib*
*deb-src ftp://ftp.lt.debian.org/debian/ testing main non-free contrib*

To install lxc and then disabled the above testing repositories.

Also, the notes that I found telling me to use the testing repositories 
didn't mention
the modifications you listed or to use the lxc-create command, so I had 
tried to implement
it like I had done for the lenny container earlier.

By the way, are there any step by step instructions anywhere?

And just to be clear, are you saying I need to install wheezy on my Host 
Node, then add the Testing repositories
to get a working squeeze container?

On 02/22/2012 04:56 AM, Bekir Dogan wrote:
> You must have:
> * "lxc.tty = ... " in your lxc config file (possibly in
> /var/lib/lxc/containername/config)
> * console in your continer rootfs: (possibly in
> /var/lib/lxc/containername/rootfs/)
> You can create this by something like this
> # cd /var/lib/lxc/containername/rootfs/
> # mknod -m 666 /dev/tty1 c 4 1
> # mknod -m 666 /dev/tty2 c 4 2
> I assume you are using debian testing (wheezy), if you create new
> containers like this command:
> # sudo lxc-create -t debian -n containername
> It asks you some questions and handles many conditions, like this one,
> automatically.
> bekir
> On Wed, Feb 15, 2012 at 03:12, Terry--gmail<terry.kemmerer at gmail.com>  wrote:
>> My problem is, I need squeeze in my containers and if anyone knows of a path
>> for doing this that has
>> some good instructions, I'd really appreciate knowing where that is.
>> This is my first query to the mail list and if I am not suppose to ask a
>> Debian Testing question,
>> please let me know...
>> So far, the only way I have found that offers squeeze, is using Debian
>> Testing, which appears to work
>> just fine, and I can ping the container both from my host and my LAN,
>> but...when I try to enter the
>> container via lxc-console, it doesn't take me to the container's prompt
>> command line....the situation
>> looks to me like probably a simple programming syntax error of some kind.
>> Below is what happens...
>> root at server:/# lxc-start -n vm101 -d
>> root at server:/# lxc-info -n vm101
>> state:   RUNNING
>> pid:      7103
>> root at server:/# lxc-console -n vm101
>> Type<Ctrl+a q>  to exit the console
>>      <<----- There is no Prompt here, and all that is visible is the above
>> instruction...and I can type stuff.
>>                  However, by pressing<Ctrl+a q>  I am immediately returned to
>> my host prompt, like so...
>> root at server:/#
>> root at server:/# lxc-info -n vm101
>> state:   RUNNING
>> pid:      7103
>> root at server:/#
>> I tried nano /usr/bin/lxc-console hoping to be able to find the offending
>> program line as I speculate it is near or at the echoed instruction, but
>> opening the program I think I am seeing binary characters in the file.  I
>> was wondering (wishful hoping) if there are any potential commands I might
>> use to just break past the point that hangs after I give the lxc-console
>> command and get a prompt that belongs to the container? Or some other route
>> to obtaining squeeze...
>> Thanks for your thoughts!
>> ------------------------------------------------------------------------------
>> Keep Your Developer Skills Current with LearnDevNow!
>> The most comprehensive online learning library for Microsoft developers
>> is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
>> Metro Style Apps, more. Free future releases when you subscribe now!
>> http://p.sf.net/sfu/learndevnow-d2d
>> _______________________________________________
>> Lxc-users mailing list
>> Lxc-users at lists.sourceforge.net
>> https://lists.sourceforge.net/lists/listinfo/lxc-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxcontainers.org/pipermail/lxc-users/attachments/20120222/93c00baf/attachment.html>

More information about the lxc-users mailing list