[lxc-users] Broken on Gentoo linux-4.8.17-hardened-r2, LXD 2.11, and lxc 1.0.8

Michael Johnson johnson at cognitech-ut.com
Thu May 18 22:29:33 UTC 2017

Hi All.

I'm very new to lxd and having very little success.

What is the absolute bare minimum required to get a container up?

I've installed lxd.

I've started lxd.

When I run: lxd init, if I answer all the question with default, I get this:

error: Failed to run: iptables -w -t mangle -I POSTROUTING -o lxdbr0 -p
udp --dport 68 -j CHECKSUM --checksum-fill -m comment --comment
generated for LXD network lxdbr0: iptables: No chain/target/match by
that name.

When I run: lxc launch images:centos/7/amd64 centos

I get this:

error: Failed to run: /usr/sbin/lxd forkstart centos
/var/lib/lxd/containers /var/log/lxd/centos/lxc.conf

and the exact failure seems to be:

lxc_container 1495144728.829 ERROR    lxc_start - start.c:lxc_spawn:975
- failed to set up id mapping

What am I doing wrong? Or is this a bug? I've seen some bug report about
failure to set up id mapping but that was in an older version and
presumably was fixed.

Additionally, is it a rigid requirement to configure a network bridge or
macvlan just to bring up a container?

Thanks for any direction or help!

More information about the lxc-users mailing list