[lxc-users] LXC 1.0.10, LXC 2.0.8, LXCFS 2.0.7 and LXD 2.0.10 have been released!

Andrey Repin anrdaemon at yandex.ru
Fri May 12 12:25:44 UTC 2017


Greetings, St├ęphane Graber!

> Hello everyone,

> Today the LXC project is pleased to announce the release of:
>  - LXC 1.0.10
>  - LXC 2.0.8
>  - LXD 2.0.10
>  - LXCFS 2.0.7

> They each contain the accumulated bugfixes since the previous round of
> bugfix releases about four months ago.


> This includes the following security fixes for which individual patches
> were made available earlier this year:

>  - CVE-2016-10124 (backport of pts/pty isolation to LXC 1.0.x from 2.0.x)
>  - CVE-2017-5985 (lxc-usernic issue for LXC 1.0.x and 2.0.x)

> It's also worth noting that LXC templates in 2.0.10 have been modified
> such that no default (insecure) user credentials are set.

Finally. I was getting tired of "deluser" for each newly created container.

> The detailed changelogs for each project can be found at:
>  - https://linuxcontainers.org/lxc/news/
>  - https://linuxcontainers.org/lxcfs/news/
>  - https://linuxcontainers.org/lxd/news/

> As a reminder, the 2.0 series of all of those is supported for bugfix
> and security updates up until June 2021.

> The LXC 1.0.x branch is supported until June 2019 with critical bugfixes
> and security updates only, users are recommended to upgrade to 2.0.x.

> Thanks to everyone who contributed to those projects and helped make
> this possible!


> St├ęphane Graber
> On behalf of the LXC, LXCFS and LXD development teams


-- 
With best regards,
Andrey Repin
Friday, May 12, 2017 15:24:54

Sorry for my terrible english...


More information about the lxc-users mailing list