[lxc-users] LXD and /dev/fuse

Sjoerd sjoerd at sjomar.eu
Tue May 10 14:37:19 UTC 2016

On 10/05/2016 16:08, Fajar A. Nugraha wrote:
> On Tue, May 10, 2016 at 8:57 PM, Sjoerd <sjoerd at sjomar.eu> wrote:
>> On 10/05/2016 15:36, Serge Hallyn wrote:
>>> Quoting Sjoerd (sjoerd at sjomar.eu):
>>>> Hi all,
>>>> I just converted a perfct working LXC privileged container with use
>>>> of /dev/fuse for mounting a webdav share via davfs2.
>>>> Now with LXD (still privileged container) I am not able to mount the
>>>> webdav share anymore and get:
>>>> mount.davfs: can't open fuse device
>>>> mount.davfs: trying coda kernel file system
>>>> mount.davfs: no free coda device to mount
>>>> I also tried to to reconfigure the container with:
>>>> lxc config device add <containername> FUSE disk source=/dev/fuse
>>>> path=dev/fuse
>>> You want to add a unix-char device:
>>> lxc config device add <containername> fuse unix-char path=/dev/fuse
>>> Does that work for you?
>> I tried it, but no luck...same error messages.
>> I tried it on the host to be sure that davfs would work there and it 
>> did, so
>> there's still something missing/wrong with the LXD container set-up 
>> ...
> Works for me with xrdp (it uses fuse to map remote drive and
> file-copy-paste support)

Hmm i see now that I can use s3ql just fine wich also uses fuse, so 
davfs2 is problematic then...
>> Any other ideas are most welcome :)
> Have you set your container to be privileged
> (https://github.com/lxc/lxd/blob/master/doc/configuration.md#keyvalue-configuration-1)?
> fuse only works on privileged container.

Yes I did..as noted in the OP ;)

Anyway I'll try to recreate the container instead of migrating it form 
the working LXC (just copied the rootfs from LXC over the the LXD 
version). Maybe that works...


More information about the lxc-users mailing list