[lxc-users] LXD and /dev/fuse

Sjoerd sjoerd at sjomar.eu
Tue May 10 13:57:38 UTC 2016

On 10/05/2016 15:36, Serge Hallyn wrote:
> Quoting Sjoerd (sjoerd at sjomar.eu):
>> Hi all,
>> I just converted a perfct working LXC privileged container with use
>> of /dev/fuse for mounting a webdav share via davfs2.
>> Now with LXD (still privileged container) I am not able to mount the
>> webdav share anymore and get:
>> mount.davfs: can't open fuse device
>> mount.davfs: trying coda kernel file system
>> mount.davfs: no free coda device to mount
>> I also tried to to reconfigure the container with:
>> lxc config device add <containername> FUSE disk source=/dev/fuse
>> path=dev/fuse
> You want to add a unix-char device:
> lxc config device add <containername> fuse unix-char path=/dev/fuse
> Does that work for you?

I tried it, but no luck...same error messages.
I tried it on the host to be sure that davfs would work there and it 
did, so there's still something missing/wrong with the LXD container 
set-up ...

Any other ideas are most welcome :)


More information about the lxc-users mailing list