[lxc-users] Mounting Ecryptfs Within LXD/LXC Container

Eric naisanza at gmail.com
Sun Jul 31 08:40:47 UTC 2016

Is there a way to mount an ecryptfs directory within a LXD/LXC container?

All I've tried so far is:

Editing, and reloading, /etc/apparmor.d/lxc/lxc-default [1][2]

|mount options=(rw, bind), ||mount fstype=(ecryptfs), |

After reloading apparmor I still get this error message:

|Exiting. Unable to obtain passwd info |

I'm wondering if anyone has already solved this

[1]: https://gist.github.com/gionn/7585324

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxcontainers.org/pipermail/lxc-users/attachments/20160731/770370b9/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.linuxcontainers.org/pipermail/lxc-users/attachments/20160731/770370b9/attachment.sig>

More information about the lxc-users mailing list