[lxc-users] using cgroups

Serge E. Hallyn serge at hallyn.com
Sat Jul 2 03:40:40 UTC 2016

On Sat, Jul 02, 2016 at 01:24:44PM +1000, rob e wrote:
> On 02/07/16 12:41, Serge E. Hallyn wrote:
> >Quoting rob e (redgerhoo at yahoo.com.au):
> >>On 02/07/16 12:14, Serge E. Hallyn wrote:
> >>>>hi Serge,
> >>>>with JUST those clauses (and no cgroup set clauses) ... it sort of
> >>>>works. Initial messages are cleared from the console(?) leaving just
> >>>>the shutdown messages. But it does get to a login prompt
> >>>D'oh.  Thanks for your patience.  I see the bug.  I'll post a
> >>>PR for a fix.  I'm surprised so few people run into this.  But
> >>>as a workaround just add ",devices" to the end of the pam_cgfs
> >>>line in /etc/pam.d/common-session.
> >>>
> >>sorry about this ... didn't work. Tried 2 forms of Pam clause & 2
> >>forms of config
> >>
> >>------------------------------------------------------
> >>PAM line
> >>session optional        pam_cgfs.so -c
> >>freezer,memory,name=systemd,cpuset,devices
> >Jus to make sure, did you log back in after this?  what does /proc/self/cgroup
> >look like?
> >
> >
> hmmm ... Now I tried the TAP TUN device (for openvpn & proxy server)
> .... FAILED .. on CPUSET

Nope, cpu and cpuset are actually two different controllers.  It's failing on
cpu.shares in the cpu controller.

Note, I think you'll be happiest if you just drop the "-c xxxxx" from
/etc/pam.d/common-session.  That will tell pam_cgfs to use all controllers.


More information about the lxc-users mailing list