[Lxc-users] Alternative to Debian Testing? No Prompt upon lxc-console execution

Terry--gmail terry.kemmerer at gmail.com
Wed Feb 22 19:08:18 UTC 2012


I am reinstalling squeeze on my host node, as I had reverted back to 
OpenVZ, so that I have clean computer to work with when I follow the 
instructions you have suggested in your second URL.

To the best of my memory, when lxc-console I got out of the Testing 
repository failed to deliver a prompt, I did hit "enter" (several times) 
and all it did was drop my cursor lower on the screen.  I also tried the 
command without the -d hoping that would get me in, it didn't....I got 
some kind of error on that, if I remember correctly.

In your suggested steps, it says:

"You might have noticed that you got yourself a debian 5.0 lenny 
container. Thats because lenny is hardcoded in the lxc-debian script and 
there is no(t yet) any squeeze compatible installer script. I have 
modified the lxc-debian script (download below try the one from the 
sourceforge archive) but it does not yet work fully out of the box. You 
can play around with it.

#> DEBIAN_VERSION=squeeze lxc-debian -p /var/lib/lxc/vm0

If you’ve already created a container with lxc-debian, you probably have 
to wipe the directory /var/cache/lxc/.. before you get squeeze (cache is 
stored not suite aware)."

Does the above command automatically pull in the squeeze version 
lxc-debian command script? --Or is the sourceforge link they provide 
which takes me to this page, 
http://sourceforge.net/projects/lxc/files/lxc/ mean that I need to 
remove the lxc install the instructions suggested at the beginning and 
instead compile the sourceforge  lxc- download somewhere?

Thanks! :)

On 02/22/2012 10:25 AM, Martin Konečný wrote:
> These may be idiotically simple suggestions, but I've been caught in 
> these situations:
> Sometimes when I use lxc-console, I don't see anything until I press 
> "enter". Try this first.
> Also, what happens if you start  the container without the -d option? 
> Does it bring you into a console then? lxc-console won't work, if 
> lxc-start (sans daemon option) doesn't bring you to a prompt (at least 
> in my experience with LXC in Squeeze).
> Martin
> On Wed, Feb 22, 2012 at 10:38 AM, Terry--gmail 
> <terry.kemmerer at gmail.com <mailto:terry.kemmerer at gmail.com>> wrote:
>     For the record, I'm not married to using Testing repositories. I
>     just need a way to
>     get working squeeze containers....that at my dummy level I can
>     create and work with. :)
>     I wasn't using wheezy, I was using debian squeeze on my host node
>     and added
>     the associated Testing Repositories to my /etc/apt/sources.list:
>     *
>     deb ftp://ftp.lt.debian.org/debian/ testing main non-free contrib*
>     *deb-src ftp://ftp.lt.debian.org/debian/ testing main non-free
>     contrib*
>     To install lxc and then disabled the above testing repositories.
>     Also, the notes that I found telling me to use the testing
>     repositories didn't mention
>     the modifications you listed or to use the lxc-create command, so
>     I had tried to implement
>     it like I had done for the lenny container earlier.
>     By the way, are there any step by step instructions anywhere?
>     And just to be clear, are you saying I need to install wheezy on
>     my Host Node, then add the Testing repositories
>     to get a working squeeze container?
>     On 02/22/2012 04:56 AM, Bekir Dogan wrote:
>>     You must have:
>>     * "lxc.tty = ... " in your lxc config file (possibly in
>>     /var/lib/lxc/containername/config)
>>     * console in your continer rootfs: (possibly in
>>     /var/lib/lxc/containername/rootfs/)
>>     You can create this by something like this
>>     # cd /var/lib/lxc/containername/rootfs/
>>     # mknod -m 666 /dev/tty1 c 4 1
>>     # mknod -m 666 /dev/tty2 c 4 2
>>     I assume you are using debian testing (wheezy), if you create new
>>     containers like this command:
>>     # sudo lxc-create -t debian -n containername
>>     It asks you some questions and handles many conditions, like this one,
>>     automatically.
>>     bekir
>>     On Wed, Feb 15, 2012 at 03:12, Terry--gmail<terry.kemmerer at gmail.com>  <mailto:terry.kemmerer at gmail.com>  wrote:
>>>     My problem is, I need squeeze in my containers and if anyone knows of a path
>>>     for doing this that has
>>>     some good instructions, I'd really appreciate knowing where that is.
>>>     This is my first query to the mail list and if I am not suppose to ask a
>>>     Debian Testing question,
>>>     please let me know...
>>>     So far, the only way I have found that offers squeeze, is using Debian
>>>     Testing, which appears to work
>>>     just fine, and I can ping the container both from my host and my LAN,
>>>     but...when I try to enter the
>>>     container via lxc-console, it doesn't take me to the container's prompt
>>>     command line....the situation
>>>     looks to me like probably a simple programming syntax error of some kind.
>>>     Below is what happens...
>>>     root at server:/# lxc-start -n vm101 -d
>>>     root at server:/# lxc-info -n vm101
>>>     state:   RUNNING
>>>     pid:      7103
>>>     root at server:/# lxc-console -n vm101
>>>     Type<Ctrl+a q>  to exit the console
>>>          <<----- There is no Prompt here, and all that is visible is the above
>>>     instruction...and I can type stuff.
>>>                      However, by pressing<Ctrl+a q>  I am immediately returned to
>>>     my host prompt, like so...
>>>     root at server:/#
>>>     root at server:/# lxc-info -n vm101
>>>     state:   RUNNING
>>>     pid:      7103
>>>     root at server:/#
>>>     I tried nano /usr/bin/lxc-console hoping to be able to find the offending
>>>     program line as I speculate it is near or at the echoed instruction, but
>>>     opening the program I think I am seeing binary characters in the file.  I
>>>     was wondering (wishful hoping) if there are any potential commands I might
>>>     use to just break past the point that hangs after I give the lxc-console
>>>     command and get a prompt that belongs to the container? Or some other route
>>>     to obtaining squeeze...
>>>     Thanks for your thoughts!
>>>     ------------------------------------------------------------------------------
>>>     Keep Your Developer Skills Current with LearnDevNow!
>>>     The most comprehensive online learning library for Microsoft developers
>>>     is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
>>>     Metro Style Apps, more. Free future releases when you subscribe now!
>>>     http://p.sf.net/sfu/learndevnow-d2d
>>>     _______________________________________________
>>>     Lxc-users mailing list
>>>     Lxc-users at lists.sourceforge.net  <mailto:Lxc-users at lists.sourceforge.net>
>>>     https://lists.sourceforge.net/lists/listinfo/lxc-users
>     ------------------------------------------------------------------------------
>     Virtualization & Cloud Management Using Capacity Planning
>     Cloud computing makes use of virtualization - but cloud computing
>     also focuses on allowing computing to be delivered as a service.
>     http://www.accelacomm.com/jaw/sfnl/114/51521223/
>     _______________________________________________
>     Lxc-users mailing list
>     Lxc-users at lists.sourceforge.net
>     <mailto:Lxc-users at lists.sourceforge.net>
>     https://lists.sourceforge.net/lists/listinfo/lxc-users
> -- 
> Open source radio in the cloud. Get yours now!---> http://airtime.pro 
> <http://airtime.pro/>
> Martin Konecny
> Software Developer, Sourcefabric
> martin.konecny at sourcefabric.org <mailto:martin.konecny at sourcefabric.org>
> 720 Bathurst St. Suite 203
> M5S 2R4, Toronto, ON, Canada
> +1 (416) 892-8420 (Cell)
> Skype: martin.konecny15
> http://www.sourcefabric.org <http://www.sourcefabric.org/>
> http://www.twitter.com/Sourcefabric
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxcontainers.org/pipermail/lxc-users/attachments/20120222/8d0bc681/attachment.html>

More information about the lxc-users mailing list