[Lxc-users] lxc-console and indents - it and joe don't get along

Whit Blauvelt whit at transpect.com
Fri Feb 17 19:36:16 UTC 2012

On Fri, Feb 17, 2012 at 01:15:56PM -0600, Serge Hallyn wrote:
> Quoting Whit Blauvelt (whit at transpect.com):
> > Hi,
> > 
> > Running 0.7.5 compiled and running on Debian Squeeze, with a Debian Squeeze
> > container, when I use lxc-console and view a configuration file for a daemon
> > which uses indents as part of its syntax, the file is displayed with each
> > line at the left margin, without the five spaces in the indents. If I ssh
> > into the same container and look at the same file, it displays correctly. 
> > 
> > This makes lxc-console useless when editing files where the indents are
> > syntactic rather than just decorative. Odd problem.
> Interesting.  I don't have this problem, with either debian or ubuntu
> containers (on ubuntu).  Maybe something to do with your terminal?  <shrug>

The terminal on my workstation is urxvt 9.09 on Ubuntu 11.04. But if I use
Gnome Terminal 2.32.1 I get the same result. With xterm 268 I also get the
same result, but with the variation that the if I scroll down through the
file the indent shows properly on the next line at very the bottom of the
console, but the indent goes away as soon as I scroll one beyond it. The
shell on the host is bash. The problem persists if I drop out of Gnome on
the workstation and go strait from the CLI.

Ah, here's the correlation. It's the editor. lxc-console doesn't like joe.
Problem isn't there in nano or vi. So what would lxc-console be doing with
Joe that's unique to their interaction? It's the only context I've seen this
problem in - and I've used joe constantly for years.


More information about the lxc-users mailing list